Jump to content

[Mutator] Official Harvester and Turret fix


Recommended Posts

Official Harvester and Gunemplacement Mutator V1.0 by RypeL from Renegade X Team



While a Patcher for Renegade X is under development a mutator is another way to fix some issues and so we want to try this out and hopefully this fixes most of the freezing Harvester issues.

How to install:

1) Move the RxHarvMod.u into the Renegade X\UDKGame\CookedPC folder

2) add "?mutator=RxHarvMod.Rx_Mutator_SmarterHarv" to the starting command of your server. So it should look something like this: "udk server CNC-Walls_Flying?game=RenX_Game.Rx_Game?mutator=RxHarvMod.Rx_Mutator_SmarterHarv"

I added the Sourcecode in case someone wants to see how it was done and how a mutator for Renegade X can look like.

The mutator includes the following changes:

- The harvester should be less likely to stop moving completly like it did mostly at the GDI Refinary on Walls.

If it still freezes you can try pushing it back on its path (like with a Medium Tank) and it should start moving again. We will replace some pathnodes on Walls in the next regular Renegade X update to hopefully completely fix the issue on Walls.

- Harverster respawntime increased by 15 seconds

- Whiteout Turrets respawntime increased by 30 seconds

Link to comment
Share on other sites

  • Totem Arts Staff

Awesome release.

Question though. Do you have a tutorial for setting up a modding environment for Ren-X should I feel like making a mutator or two?

I've installed the UDK 2014-02 version, and have been trying to work on my friend's old mutator for beta 2 (maybe 1?) he made for his irc bot. I've gotten stub types from Ren-X in a RenX_Game package, as well as edited UDKEngine.ini to include RenX_Game and my package (RenX_Game above my package, below UTGame). However, when I run a compile (also tried "full") in UnrealFrontend, but it just stays on "analyzing" when it gets to RenX_Game.

To clarify, my friend's (link) mutator extends Rx_Game and provides a secondary tcp logging system for extended communication between the server and his bot.

Link to comment
Share on other sites

  • Totem Arts Staff

I think that's because those packages are cooked

Would love to see the release source code of Ren X to.. you know, fool around... but it's not very likely, plus problems will arise, like custom builds that are totally broken and cause builds to pile up that it's hard to determine the official ones

Link to comment
Share on other sites

I will post the Ren X source later on. You can already get most of the Ren X sourcecode from the cooked packages, thats how some people already made mods and mutators. To ease the process of getting the source i will post it at the weekend, hopefully together with a little tutorial about mutators, if i can find the time.

@Genesis2001: Not entirely sure atm what could be your problem as i obviously have a different setup with the whole dev build. Not sure atm/forgot what it will be like when you just have Beta 3 and UDK. I didnt do a mutator like that in years. Will have to look that up again/try it. Maybe it will work for you with the full source package or else its something else you have to do with the inis. My guess is that it might try to recompile RenX_Game and that will never work (and isent supposed to) without the full RenX_Game src, it should only try to compile your mutator package.

Link to comment
Share on other sites

  • Totem Arts Staff

I used UE explorer to extract RenX_Game.u and removed the function bodies as I only need the thing to compile. I also only added what files I needed and commented out references to some other files that my mutator wasn't using. Essentially a stub type to let the compiler know it exists.

Link to comment
Share on other sites

Thanks, going to test it.


I tried to compile my own mutator but I got the error that Superclass UTMutator of class xx not found.

Shoulden't it be UDKMutator for the UDK version renx uses? I used the development kit from the guide posted on these forums

I got the exact same error.

If you do make a mutator tutorial RypeL, that'd be fantastic. :)

edit --

Fixed it. First thing:

[01] you need to install the UT sample game withthe udk

[01] with the *

[01] ah

[01] thanks!

And then:

I don't know if this is right, but changing the line that we put in UDKGame/Config/DefaultEngineUDK.ini from




make it compile correctly for me!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...