Jump to content

Can't Join Some Servers


Recommended Posts

Me: "Oh cool a new Renegade update! I can't wait to try it out!

Computer: "No I don't think I will"


Righty then, after this new update there are some servers I just cannot join.

I open the multiplayer tab and get my list of servers. I click join and nothing happens. The main menu keeps going as if I had clicked on nothing. No matter how many times I click on the server to join, it refuses to do anything. This is with only some servers though, as some work fine.

Works: CT Marathon, CT survival, Fairplay Marathon usa

Disobeys me and must be punished (doesn't work): GDI vs GDI, Team Deathmatch, Fairplay marathon UK

I have tried everything I can think of.

  • Verify game files
  • Re-install game
  • Gave permission for all Renegade X files to do whatever they want on my PC
  • Both 32 and 64 bit
  • Default settings
  • Launch with and without steam
  • Insult computer

To no avail.

If I were to guess what the problem was, I think it has something to do with downloading server mutator files. Notice how all the servers I can't join have users download a few files before entering the server. I deleted my RenX files in program files 86 and re-installed the game. Then gave those files permission to do what they want. So I figured that would allow them to download the mutator files. But it does not appear to have worked.

What are your thoughts? Am I right in my assumption but didn't apply the right fix? Love to be able to test out some Steppe with 64 players.

Let me know if you need any hardware info or even a video of what my main menu does.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...