Jump to content

LandscapeVisibilityMask node missing in material editor


HIHIHI
 Share

Recommended Posts

Hello!

I've been playing RenX for a few months now, and I have started to make my own map, with the help of kenz's tutorials (Thanks kenz!). I would like to add some tunnels through my landscape. The way people say to do this (as far as I can tell) is to set up your landscape material with masked blend and then plug in a LandscapeVisibiltyMask node into the OpacityMask part of the material, after which you can use the visibility tool to paint away landscape. The problem is that this node does not appear in the node browser. I can search for "land," "vis," "mask," etc, but I can't find it.

My SDK is from March 3, 2017. (I know it's old; I just didn't want to download a new one in case I decided mapping wasn't for me. I would have the newest one by now but someone said in-game that there was an update planned and to hold off until then.)

Anyone know what the problem is? Or is there no problem and it's all me? : )

Thanks, HIHIHI

Link to comment
Share on other sites

  • Developer
22 minutes ago, HIHIHI said:

Yes, but doesn't the material have to be set up with a LandscapeVisibilityNode in the material editor? Currently if I use the eye tool, it just removes all textures from the landscape component I use it on. Anyway, I will get the new SDK version and work with that.

Thanks, HIHIHI

It shouldn't matter what version you have... I don't think we've added new nodes to materials before.

Link to comment
Share on other sites

Well, I've found a limitation. I lose all textures in a component of my map if I try to:

1. Paint more than four layers in that component, or

2. Paint more than three layers in that component if there is a landscape visibility hole.

Is this a known SDK limitation, or do I have something set up wrong? I tried on Whiteout and was able to have all five layers of its landscape material and a visibility hole in the same landscape component.

Thanks, HIHIHI

Link to comment
Share on other sites

  • Developer
2 hours ago, HIHIHI said:

Well, I've found a limitation. I lose all textures in a component of my map if I try to:

1. Paint more than four layers in that component, or

2. Paint more than three layers in that component if there is a landscape visibility hole.

Is this a known SDK limitation, or do I have something set up wrong? I tried on Whiteout and was able to have all five layers of its landscape material and a visibility hole in the same landscape component.

Thanks, HIHIHI

DirectX9 or something limitation I believe

Link to comment
Share on other sites

  • Developer
21 minutes ago, HIHIHI said:

Root of problem: My landscape material had too many texture samplers. It was at 12/12 max. I simplified it to have 10/12 and now I can paint five layers and a hole without a problem.

Again, thanks for your help!

No problem! The dev team is happy to see community members experimenting and creating! We are happy to assist you and answer any questions you may have.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...