Jump to content

Oddly specific launcher issue


Recommended Posts

For awhile now sometimes opening the launcher completely freezes my computer; video freezes after launcher menu pops up and audio sounds like an amplifier was un-plugged. I then do a hold-the-power-button-for-5-seconds reset and everything is back to normal after reboot.
This time though, the crash happened on the first launcher start up after todays quickfix patch.  After rebooting i can no longer open the launcher at all ( mouse pointer gets an hourglass for a second and there is CPU activity but nothing happens ). When this crash happens, it is the instant i double click and the launcher pops onto the screen. It has happened more times then i can remember ( tens of times ? ), and has never led to a permanent issue like this befor.
I tried to uninstall / reinstall the launcher, and i tried the repair option with in the installer. I tried bypassing the desktop shortcut. I have reset my computer. Windows 10 is up to date. Flash player is up to date ( does the launcher use flash player ? ). My nvidia drivers are very recent ( end of 2019 ).

Edit :
- RenegadeX Launcher does NOT show up in task manager befor or after trying to open it. As in, its not stuck there, needing to have the task terminated manually. It DOES show up in taskmanager for a fraction of a second while being double clicked.
- The launcher DOES show up in resource monitor, twice, as a grey'd out task that shows as ' terminated ' the moment it pops up. There are no options when rightclicking other then search online.
- I tried right clicking on the launcher and opening as an administrator. No results.

I can load the game manually and join a server that way. I asked players in game if anyone was having launcher issues after todays patch and no one said yes.
I think the crash broke something on my end and i dont know how to fix it.  What programs does the launcher use ? Since i reinstalled and repaired the launcher with out any change to my issue, i asume i must look else where for corrupt files or what ever.
Also from what i can understand i am stuck now ? as in; i cant reinstall OR update the game with out having a working launcher ?

Edited by They
Link to comment
Share on other sites

Please attempt the following:

1. Add exceptions of your launcher executable to your antivirus(es) and firewall.
2. Close any overclocking/hardware monitoring programs such as Rivatuner, MSI Afterburner, or ZOTAC Firestorm.
3. Right-click the Renegade X folder -> Security tab -> Edit -> Users -> Allow as many boxes as you can.
4. Right-click the launcher executable and select Properties.
Under the 'Compatibility' tab, test with 'Run this program as an administrator' both on and off.

If that doesn't work, proceed with the following:

Place the attached binary in your Renegade X/Launcher directory, alongside the original.
Run the new variant, and then paste the newly created log file here.

Renegade X Launcher_debug.exe

Edited by DugeHick
Link to comment
Share on other sites

His issue is/was with the launcher specifically.
He can still join games manually.

The binary I submitted contains additional log commands near crucial calls.
So that we can see exactly which call results in this uncaught exception. (e.g. this old bug occuring at InstanceHandler.cs line 20)

With the intent of figuring out which redist/permission/system files need reconfigured.
I know it looks like -and probably is- a permission issue but that code is in a try-catch block and *should* not crash like this.

Edited by DugeHick
Link to comment
Share on other sites

I saw another post where someone fixed their launcher no load issue by creating another windows account and loading the program there.  I did this, the launcher loaded no problem, asked for me to choose a name and updated game.  So at the moment, i can load the launcher no problem on my new windows login, but after switching back to my original windows login the launcher will not load. Not exactly a fix since i prefer to use my original, customized, windows account and don't want to re-do everything. This method will allow me to patch the game but did not fix the launcher. With out this work around i would have no way to patch the game.

I followed the instructions and placed the launcher_debug beside the original and ran the program. A new instance of the launcher seemed to load. The " Welcome back commander " name selection mini-window popped up for me to choose my name, then my 2nd monitor went black and my computer froze ( when running the launcher crashes my computer, one of my monitors always goes black ). After rebooting my computer, the new launcher_debug will not run.

I will include the log files.... To be clear; i tried to load the new launcher twice. Semi-successfuly with an instant crash. Then right after reboot with no apparent result. I don't know if this will effect the log results



Edited by They
Link to comment
Share on other sites

So... i never figured out what made the launcher regularly crash my computer befor, the only thing i might have noticed is when my machine has been on for along time, loading the launcher will probably crash it. Fresh windows start ? the launcher probably WONT crash the computer.
So when i loaded the new launcher_debug today, my computer had been on for along time and ofcourse; a crash happened right away. I am worried now that this might prevent useful info from making it to the logs ?
Has the crash disabled the new launcher_debug from working on my original windows login ?
Are the log files from the new windows log in useless since theyre not reporting on the issue ?
I think that the same crash that has bugged / blocked the original launcher.exe has now happened again, which has disabled / blocked this new launcher_debug. If i could somehow get another working version of the launcher_debug. Then to try running it right after a reboot to see if it will load with out crashing ?

Link to comment
Share on other sites

All permissions were already set to allowed, except a grey'd out option at the bottom of the list " Special permissions " which has both allow / deny boxes grey'd out. Im not able to alter this option on any user.

I ran the new launcher_debug2.exe after restarting my computer and it worked no problem. Can this new program be used as my launcher now or is it for debug only ?
Here are the logs after opening and closing launcher_debug2.exe :


Edited by They
  • Haha 1
Link to comment
Share on other sites

It's funny because I haven't actually implemented a fix yet. We're still tracking the error.
Apparently your matter has suddenly been resolved. Log is looking good indeed.

My guess is, that the original launcher executable will now run OK too.
As I haven't actually implemented any fix in the _debug2.

But if the normal one still doesn't work: yes you can definately use this one too.

Should this issue come back to haunt you later on, proceed with the following:

1. Secure and attach a fresh new log here that is created right after the failure to start.
This should give us very specific information as to how and why this is happening.

2. Now delete the content of that %localappdata%\Totem_Arts folder, leaving the folder itself intact.

If that doesn't fix it:
3. Tell us what subfolders and files are being created in there. Attach the file(s) here.

So for now enjoy your working launcher and glhf. :) 

Link to comment
Share on other sites

The original launcher and launcher_debug1 DID NOT start working untill i tried your last suggestion of manually deleting the contents of this folder  ->  %localappdata%\Totem_Arts    ( I removed the files and saved them incase they are important ).
Launcher_debug2 was working but it DID NOT solve the problem of the original launcher loading. Original launcher did NOT work after i sent my last log files.

This crash has been quite common for years now but only recently did it lead to disabling the launcher from working. Twice ? ( see above experience with launcher_debug1 ). Did something change in a game patch this year that would cause this crash to disable the launcher ? 
I would love to know how to prevent this crash as it forces me to powerdown my machine. Right now all i have to go by is .... : only start the launcher after a fresh reboot and just keep it open but minimized. If i close the launcher by mistake, reopening will probably crash my machine and now disable itself from working.

Thankyou so much for your help !

Link to comment
Share on other sites


So our quick bandaid is to:
- delete the content of the %localappdata%\Totem_Arts folder
- simply rename your launcher executable to something different every time; should do the same thing

Should you want to (help) find a more permanent cure for the community, and/or the issue occurs again for you, proceed with the following:


1. Make sure you'll be using the _debug2 version, renaming it to whatever you like
2. Right after the first major freeze-crash: secure the log file before you do anything else
3. With the log file secured, now try launching again; it will do "nothing"
4. Secure the new log file as a 2nd
5. (double-)Check the permissions specifically of the config file(s) deep inside %localappdata%\Totem_Arts
Have you clicked through every user/group?
6. Upload those config file(s) and both the log files here

Do crashes like these occur in other games or programs aswell, as in: ever at all?
And do you ever have BSOD's? (usually auto-rebooting)

Update all your drivers (not just nvidia) automatically here: https://www.driverscloud.com/
It may just be something like your LAN driver.

You're welcome!

Edited by DugeHick
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...