Jump to content

Starting a LAN Game, struggling


nctnl
 Share

Recommended Posts

Hi there,

I've checked out Ren X over the past couple of days, really impressed, really enjoyed it.

I get together every few months with friends and we have a lan party, about 8-10 of us.

I've been tasked with getting this running for LAN, but don't seem to be able to start the game:-

1)Have run a server from the launcher, then run the game from same PC and connected to server

2)Have run the game on another PC and connected to the server.

3) Screen is constantly stuck on Match starting in 4 seconds or whatever the text says relating to that (at work on my lunch break atm so can't check).

 

My question is, is there a way to force the game to start, or is there a minimum number of players required before the game starts?

Many thanks!
nctnl

Link to comment
Share on other sites

Glad to hear you like the game. There's isn't a default minimum number of player required to start. You can turn off the waiting for players time by using the config files. Look at the wiki for details on server setup and settings. I haven't heard of the game getting stuck at 4 seconds before. There maybe other who have experienced it before, tho. Try turning the waiting time to 0 and see if that solves it. If it continues to be an issue, post the log files.

Link to comment
Share on other sites

Thanks for the speedy response ShrewdTactician,

I'll give that a shot, I've also been PM'd a guide on how to get a dedi running from a batch file, so will test both methods tonight and post back here with an update just incase anyone else experiences the same issue.

Cheers

Link to comment
Share on other sites

Ok. issue is sorted.

I think the problem was related to the following:-
 

USING SERVER LAUNCHER
Console was giving me an error about not having the map CNC-Walls_Flying, so it said it would load default map instead.

I tried to change the map it loaded through config's and didn't manage to get it to work; watched the console and it still tried to load CNC-Walls_Flying and then went to default map.

The issue this seemed to cause is that I was stuck in the lobby, with one client stating Match was about to start in 4 seconds, but some different text (something about game tips or keys, I forget) on the second client. Could see both clients names in the lobby, and definitely in the same server.
 

USING BAT FILE
Used limsup's guide, loading up through a batch file, bit easier, and worked first time.

 

Not sure what I was doing wrong using the first method, but happy with how it's working now using a batch  file.

Worth noting, my friend had this same issue, which is why he asked me to look into it.


Thanks for everyones speedy responses and help.
 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...