Jump to content


Recommended Posts

Hi Guys ! Big Fan and love your work on the franchise !. 

Had some serious issues lately about the game, since 5.24 my performance dropped severely to a point of unplayable on max settings (4k and all turned on). It is shown as severe stuttering on the game (not related to lag or latency). I solved the issue by lowering the Nvidiafx antialiasing to a lower value (from 5 to 4) and all was well, now after 5.25 it got far worse, now i cannot play fluently without lowering my resolution to full hd (got a 4k LG tv so I can run 60hz only on full HD and 4k) and turning it off to standard MSAA. While curious why I noticed that when i turn off the main character UI by switching for a moment to the map or player list the staggering stops or gets much better, still small staggers. Any advice would be great as the game looks fantastic on max.

Now the Constructive Tyranny custom maps... while fun it became a complete nightmare, the renx launcher kept stuck on downloading maps (got a 300kbps net so quite limited) even after restart, any time i tried to join the server the download would restart from the beginning and try to download the whole pack, my fault as probably i shouldn't have tried to join the test server. Still, I had to do a verification and repair like 5 times in a row every time it tried to download a map automatically. So, I downloaded it manually from the website as prompted and while it identified the maps it kept trying to download them again, much faster this time... no idea if related but the staggers began to be unbearable after that.

All my problems apply to all maps, official or not now. 

Any advice or information welcome. Cheers !

EDIT : also had the same issue with the launcher not auto updating at marath server, after a play the game crashed, had to repair the installation which rolled back to previous patch, now i cannot join at all.


Edited by Maestro
Link to comment
Share on other sites

This Is not 100% related to the custom maps as the Launcher doesn't alter RenX core files, so verification afterwards shouldn't be necessary. It could be that the CT server uses different maps than the one you downloaded (In versions), so the seeker kicks in to download the correct one. If you are having more problems with the Auto map downloader, you can toggle it in the settings. The only advice I have at the moment is to try a reinstall of the game via the MSI.

As for the other visual problem, I know the UI has a performance problem on higher resolutions but I'm not the UI dev. Maybe someone else can clear this up? Also, what GPU do you have?

Also: moved to technical support.

Link to comment
Share on other sites

Thanks for a fast reply, did not expect it to be a priority as a performance issue, ok what I will do is a complete re-download and reinstall of the RenX without the custom maps and with them to see the difference.

I got a MSI 4G GTX980 x2 SLI, running newest NVIDIA drivers and have issues only on the NVIDIAFX, and on higher than 1080p. Not complaining, just want to inform you guys of the problem. 

If there is anything I can help with or assist please do not hesitate, I am open to beta testing as well.

Link to comment
Share on other sites

37 minutes ago, Maestro said:

I did a full reinstall and all is working great. Excluding the performance issue on 4k. But I am really just happy it launches the game. Did a reinstall and custom maps work too. I guess it was something with the versions not matching. Thanks !

I used 4 x GTX Titan before. After mid-2015, Renegade-X does not support SLi anymore due to updated UDK version. I suggest that you sell the 980's and get a single Titan X (Pascal).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...