Jump to content

Building lights = CRASH!


it8fun
 Share

Recommended Posts

I'm not really sure if it is my machine that is just crap but when i try to build lights on my map in "preview" mode it takes about an hour to run and then when it gets to the process of building the light maps it just crashes halfway or 3/4 of the way through. I'm not really sure why it is doing it. A couple of times it has linked me to some files but they were not even referenced into my SDK file folder or the drive that the files are held in.

THINGS I HAVE TRIED

*This first happened when i tried to build high lighting so i moved it to medium and it still did it. So then i went to preview and it still crashed.

*At one point i had multiple version files of the map so i got rid of them and just had one file that is up to date. Ran light build in preview and still crashed.

*I have restarted my PC and tried to build lights in preview still crashed.

I'm not really sure why it is doing this. It didn't do this any other time but is doing it now.

I have around 900+ light maps that i have to process. I'm not sure if this is just way to many and i did something wrong and that's why it is taking so long to build lights and my machine can't handle that many light map processes so it crashes.

MACHINE SPECS

GPU: GeForce GTX 960

CPU: Intel® Core i5-4690 @ 3.50GHz (4-core)

Memory: 16.00 GB RAM

OS: Windows 7 Pro

Link to comment
Share on other sites

  • Moderator

I have my own question and have been holding off until yours was answered. Since it hasn't, and I am no skilled udk expert, I draw upon my general computer skill and speculate perhaps you are either running via 32b and teaching 4gb ram usage which is all any 32b app can consume, or are running 64b and reaching total available system ram. If the latter, Google how to increase your virtual memory, which allows some hard drive to act as painfully slow ram. Might take a day to build lights.

Alternatively, I heard of some way to build lights via multiple machines through Internet. Look on TeamSpeak or irc on any of the renx servers, particularly Encrypt would know how to do it, I think he did it with carnage club.

It doesn't look like your machine is weak. Lastly, could just be the lights are plain old errored. Could be any one of them, might be a pain searching for which one isn't building and crashing instead

Link to comment
Share on other sites

  • Developer

Maby i know about the Problem i got it too so Ruud033 helps me with that and it works!

Try this out:

Here's the setting to look for: LightmapResolution

adae72ae3dc9142411db70d9ca33b835.png

That's for the foliage.

Now for static meshes, you can set them in that same window OR, override them here:

c309e7e5e46ac9a8af8d605abe24b321.png

The Lightmap resolution has nothing to do with size and scale of your mesh itself.

I set the Cross to "Override the Light Map Res" and put 8,16 or 32 down to the next ( I choose 8, it works and Light Builds works now without any Problems)

4 Core is possible not enough to manage this insane Number of hight detailed Shadows on a Meduim/Large Size Map.

Link to comment
Share on other sites

Alternatively, I heard of some way to build lights via multiple machines through Internet. Look on TeamSpeak or irc on any of the renx servers, particularly Encrypt would know how to do it, I think he did it with carnage club.

If its not possible to build on 1 machine it is not possible to build with 2+

The only difference is the amount of time required to build. I build like this all the time as well.

on topic : please disable shadow casting for any object where the shadow is never going to get noticed from! (background trees etc) or set the light map resolution really low if you really want to get a shadow!

For things that you're able to see up close, you want to set the resolution either to 64(really detailed) or 32(acceptable)

Note that there is a tree in the game (the one from the screenshot @ DaKuja) that has a light map resolution of 256(insane) by default! Set this to 64 maximum.

Lights in tiberium fields, turn shadow casting off at them. They do not require a shadow and dynamic objects (vehicles, players) have to calculate the shadows - >performance hit. Also, be care full with using smoke / particles in general and shadow casting, the particles also interfere with the shadow, which again has to be calculated.. Bla bla bla

Also, try using 64 bit, I always do it

Good luck!

Edited by Guest
Link to comment
Share on other sites

UDK particles does not emit or receive shadow afaik. If you look at the projectiles (which is emittes by Particle System as well, they never give any shadow

UE4 starts that thing, but we're in still in UDK

True, but what I meant was that particles affect the rendering process even more with shadows.. might have used the wrong words there.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...