Jump to content

FPS limitation


Axesor
 Share

Recommended Posts

Hey I just wanna ask, if there is any option to limit FPS? Summer is coming and my notebook starts to overheat=game starts heavy breaking for like 5 minutes and then it goes smoothly untill it overheats again.

I'd like to limit my FPS to like 30-40 frames to prevent my computer from overheating and game breaking.

I know some games have this option and it would be nice if this option was added to setting's of this game.

Link to comment
Share on other sites

  • Moderator

You could try and run udk.exe with this param udk -fps=24 but i've read that the free version udk ignore that? Plus ive never tested it myself lol

(note i'd make a bat file in the game dir with udk.exe and paste in udk -fps=24 and run the bat file n see if it makes any diff)

Hope this helps.

Goks

Edit: also try F5 Stats FPS in game so you can see your true fps. Maybe there is a FPS option in the console? Just a thought.

Link to comment
Share on other sites

Yes there is. Look for a smooth frame rate setting or something like this in the inis. You need to activate that plus setting the frame rate cap (also in the ini close to the smoothed frame rate setting). It might be the systemsettings.ini but im not sure atm (not at home).

Link to comment
Share on other sites

Since today I am using Nvidia inspector for limiting FPS and its working fine (well, sometimes it turns off FPS limit by itself so I have to rewrite it and run RenX again. Its just annoying). Main problem is that I dont feel confortable when I have to turn on/off limitation everytime when I wanna run another game (for example Robocraft) where I rly dont need 30 FPS limit. So I'd like to find solution in "core", change some values in file.

Gonna try this "-fps=24" thingie. If it wont work, guess I must live with it :P

Thank you all for your responses.

Link to comment
Share on other sites

Hmmmm I can't really help you much... let me check UDK's documentary

hmmm found something. In the shortcut's properties, add '-fps=24' at the end of the Target textbox. Don't add the quotes btw

Lowering settings will force a higher frame rate and that's part of the problem. Even on a desktop that has decent cooling if you let the main menu idle too long and it's hitting 300+ you might end up damaging your card (happened to people in tribes ascend). Smoothframerate fixes that

If smoothframerate actually works for someone here since B4, can they post their UDKEngine.ini [iniVersion] lines? (near the bottom)

Link to comment
Share on other sites

I followed this instructions: http://eliteownage.com/chivalryfixes.html

With this i limited fps to 30 for testing and it worked perfectly for me. Note that you need to change UDKGame\Config\UDKEngine.ini and Engine\Config\BaseEngine.ini

Search for "bSmoothFrameRate" and change to to TRUE, and set MaxSmoothedFrameRate=60. You have to change this in 2 spots in each of the files.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...