Jump to content

Recurring issue, massive framerate loss (Need dev)


Recommended Posts

This only happens in two games I play: Rise of the Traid (Remake) and Renegade X. They both use the UE3.

Here's what happens: During the game I run at 100+ frames for a good while, but after 3 to 5 minutes the framerate massively drops. Sometimes it goes into the twenties, sometimes it goes into tens.

When I run this game in windowed mode and click to view another program, the framerate goes back up in the background to the normal state. When I click back into the program the framerate drops again.

During the problem my GPU usage ranges from 5% to 15%, when the game is running fine (both windowed and before the problem starts) it ranges from 75% to 99%. Temperatures don't exceed 80C, even while the game is running fine in the background. So I'm sure it's not overheating and it won't overheat if it were to keep at the normal frame rate.

My CPU usage goes up a lot during the problem. Up to 70%.

I can have the problem go away temporarily by "dusting" my GPU out, but that only stops it for a bit then it comes back a few days later (longest has been one week). I've tried framerate smoothing and V-sync. Both do not solve the problem.

My specs:

GTX 570 (PNY, Stock)

i5-3570k (stock clock)

P8Z77-LK Asus MOBO

G.Skill Sniper 1866mhz Memory (2x4gb)

HX850w corsair PSU

Game runs off of a Sandisk 128gb SSD, but this is irrelevant since I have the same problem with Rise of the Triad and that runs on my WDblue1tb.

EDIT 3: To hell with pastebins here's .log files. Pretty much at the end of the log files is where the problem starts.



Edited by Guest
Link to comment
Share on other sites

80C is pretty close to the red for that card. My guess would be the v-ram on the card. Wouldn't happen to have another on hand to test, would you?

I'll see what I can do about another card.

This game seems to only use 400mb of my VRAM while TW2 will use 500+ of my VRAM. I run at 1600x900. Any other way to tell if VRAM is bad?

EDIT: I used a program called "Video memory tester" and it reported no errors and used 1gb of my video memory to test out of 1280.

Link to comment
Share on other sites

UPDATE: Well I feel sort of dumb right now. When this problem first started I figured it was my PCIE cables that went from my PSU to my GPU. They were extremely bent up from trying to fit them in my small case where my hard drives used to be (old case). I moved the Hard drives thinking this was the problem at first, and it worked for a few days but then it went bad again. Just now I put in new cables (good ole modular PSU) to my GPU and it seems to work great now. It's getting clean power I think and I'll monitor it. I hope for anyone else who has this problem they find this thread. Now I just gotta re-do my cable management, damn it.

Link to comment
Share on other sites

HUGE FUCKING UPDATE: I found the real problem. It wasn't my cords. It wasn't even my GPU. I have an adapter for a WII U PRO CONTROLLER from "Mayflash" and I found out that when it is plugged in, my game runs at a horrible frame rate after a few minutes. I have seriously found the issue this time and this thread should be forever closed so I don't triple post a shitload anymore.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...