Jump to content

Linux: Dedicated Server Setup Guide


Recommended Posts

DISCLAIMER: Follow this guide at your own risk! These are the steps that I had to follow in order to get the (Windows) Dedicated Server working in a Linux OS.

NOTE: This guide should more or less be the same for most of the major linux distributions, the package installer will change depending on what OS you're running (Eg. pacman for Arch).

NOTE: As far as I can tell, it is currently impossible to run a dedicated server without having some form of GUI :/

NOTE: I'm assuming that you know your way around a Linux system, I'm not going to go over the basics here.

NOTE: Apart from the package installs, you should not need to run any command as the root user.

Hello! This guide will hopefully show you what you need to do in order to get the Renegade X dedicated server running on your Linux server.

This guide was ran on a Ubuntu 12.04.2 LTS server.

1. Install Wine:

sudo apt-get install wine

This will install Wine along with everything needed to get a basic VNC Server running.

2. With Wine installed, we can now install the required libraries.

Run the following commands:

set WINEARCH=win32
winetricks -q dotnet40 xact_jun2010 vcrun2010 d3dx11_43

This will install the required libraries.

3. Upload Renegade X

You'll need to upload a copy of Renegade X to the server, since there's no GUI to use the installer.

Once uploaded, configure your server settings.

4. Starting The Server

You'll most likely want to use something like screen to run the server, unless you intend to run the server only while you're logged in.

To start the server, do something like the following (These commands will more or less be the same as if you were starting up a Windows Dedicated Server, apart from the fact that you use UDK.com instead of UDK.exe):

wine cmd
* Wine CMD Starts... *
UDK.com server CNC-Field?AdminPassword=password123?maxplayers=40 -port=777

At this point, the server should start, and you should be able to connect to it :D! The VNC Viewer window can be closed at any point.

If you have any feedback, or feel that something should be done differently, let me know.

Edited by Guest
  • Like 1
Link to comment
Share on other sites

Actually, it might be possible to do it all from the command line. You can definitely run the server from the console using UDK.com instead of UDK.exe (Can see the output, but can't write commands that way it seems), I'll need to look into configuring wine though the console, though.

Edit: I've gone and altered the guide to (hopefully) not need a GUI, not too sure about the winetricks commands though.

Link to comment
Share on other sites


after following the guide and run the command i get:

"wine: Install Mono 2.8 or greater for Windows to run .NET 4.0 applications."

What is the problem here?

From the looks of it, .NET 4.0 didn't install properly (Installing this is a bit of a hit and miss, sometimes it fails because "It's Already Installed").

What version of wine are you running? The following command will tell you:

% wine --version

Link to comment
Share on other sites


now i get:

Z:\home\gs\renx\Binaries\Win32>UDK.com server CNC-Field?AdminPassword=password123?maxplayers=40 -port=777

Application tried to create a window, but no driver could be loaded.

The graphics driver is missing. Check your build!

Link to comment
Share on other sites

  • 6 months later...

I'm currently working my way through your tutorial. Thank you for it. I'm using Debian 7 and after installing wine there wasn't winetricks automatically included. So you have to install it by its own:

sudo apt-get install wine winetricks

Maybe you want to update the tutorial. Will report any further errors/problems or if the server runs smoothly and fine :)

Edit: vcrun depends on a graphical desktop :/

renx@RenInsX:~$ winetricks -q dotnet40 xact_jun2010 vcrun2010 d3dx11_43
Executing w_do_call dotnet40
dotnet40 already installed, skipping
Executing w_do_call xact_jun2010
xact_jun2010 already installed, skipping
Executing w_do_call vcrun2010
Executing load_vcrun2010
Executing mkdir -p /home/renx/.cache/winetricks/vcrun2010
Current wine does not have wine bug 23427, so not applying workaround
Using native,builtin override for following DLLs: msvcp100 msvcr100 vcomp100
Executing winetricks_early_wine regedit /S C:\windows\Temp\_vcrun2010\override-dll.reg
Executing wine vcredist_x86.exe /q
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.

Link to comment
Share on other sites

  • 2 months later...

There's a simple way to get a "Display" if you're using Windows as your home system:

Use putty as ssh login tool

Use VcXsrv (from sourceforge) as X-server at home

At putty enable X11forwarding (Connection->SSH->X11)

At VcXsrv disable access control

Install xauth on your server

Enable X11 forwarding in sshd, and restart sshd as follows.

$ sudo vi /etc/ssh/sshd_config

Search for X11Forwarding and change it to yes (if a # is in front and no other line without, remove the #)

$ sudo /etc/init.d/sshd restart

Logout and -in, you should get a message that an .Xauthority file has been created.

If it's still not possible to start a software with a display, check the log files of putty (via right-click at topbar) and the VcXsrv (at tray). Maybe you have to set at putty X11forward or install xfonts on your server.

Hope that helps. :)

Link to comment
Share on other sites

  • 1 year later...
  • 1 year later...
  • Agent unpinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...