Jump to content

Two issues after latest RenX update v5.12 -> v5.14


Recommended Posts

Hello there,

I try being quick in explaining:

After latest update, RenX won't log-in into Steam but Steam's UI and Broadcasting are activated in-game. I downloaded the Launcher hotfix (0.55) which also has a nice "Skip Intro Movie" option. No more .BAK'ing them anymore. The Launcher seems to doesn't work properly, just the quotes are gone in-game and RenX still doesn't recognize me as a Steam-user.

I am going to re-download Renegade-X so. There might be a/some corrupted file/s anywhere.

The 2nd issue is on your download page:

The german "[AOG ]Area of Gaming" link to the RenX file downloads a bit more than 700mb, file corrupted!! Any other links download @ ~50kb/s to ~300kb/s while the german one gimme full speed. Way too slowly, download will be finished in around 3 hours. Please let the hosts know about this.

Edited by Guest
Link to comment
Share on other sites

It doesn't matter where I live and who my ISP is. I dowloaded the full/complete 3.1GB installer via US mirror, installed RenX v5.12 so, auto-updated to v5.14 and same issues happen as I described them in my 1st post.

I am able to play Renegade X, just without being recognized by Steam and so my ladder stats won't be written.

Link to comment
Share on other sites

It doesn't matter where I live and who my ISP is.

That information would help me to pinpoint the issue with the servers.

The Ren-X community doesn't have lots of money to throw around for servers so sometimes folks will have issues with some of them. We try our best to resolve the issues but we need help from the users.

Link to comment
Share on other sites

I sadly don't know why that problem happens. A few of our CT core group have the issue as well and we have yet to fix it. Schmitzenbergh has a new version of the launcher coming soon but I'm not sure if it's a launcher issue or some issue with the game using the steam API.

Please do PM me your connection info though if you don't want it shared. I would much appreciate it.

Link to comment
Share on other sites


I think problem 4, is Steam not syncing to Ren-X while both are open.

Solution was deleting the Launcher. Note, it's the Launcher and not the game itself you must delete. It hasn't been determined how this happened, but this started becoming a problem just Feb. 2nd upon that date's Steam Update. It updated, and if you are familiar with GameJolt and it's UserTolkens, for some reason the update broke some user's ability to make the darn game detect their darn user session.

So just delete the launcher and reinstall the launcher, not the game itself but just the launcher.

If you have already done that, then you are one of the first that have deleted the launcher and had this problem persist. I would suggest you delete the Steam client and reinstall the Steam client, while specifying in uninstall to not delete games or save data and just the Steam client. It might have old cache causing issues, because there isn't much the game can screw up in terms to "hooking with steam", the launcher either does it or it doesn't, so it could be Steam not giving it a good hook for some reason.

Link to comment
Share on other sites

Yep, I did read that page and so deleted the Launcher's directory. Had used the 0.55 hotfixed Launcher afterwards but without a success as I already mentioned. So, I will retry this procedure but instead to use the 0.55 Launcher, just reinstalling the 0.54 one.

If this won't work, I will think about reinstalling/repair my Steam Client.

Link to comment
Share on other sites

Alright, I post here the steps I did to mention that conclusion I've got:

* I deleted the Launcher directory

* I wanted to reinstall the Launcher via "RenegadeX-OB5G.exe" [3,10 GB (3.336.525.446 Bytes)]

* Installer deleted the RenX directory and completely reinstalled everything

* Allowed to auto-start the Launcher after installation

* Auto-Update v5.12 -> v5.14 proceeded

* Started Renegade X afterwards

* Steam recognized me and everything worked as well as the ladder stats

* Closed and re-started RenX via an added shortcut on Steam

* Steam wasn't be able to recognize me anymore

* Closed RenX

* Started RenX directly via "Renegade X Launcher.exe" (v0.54), not via a Steam shortcut

* RenX works again as it should

So, in a way Steam won't recognize me whenever I launch Renegade X via a shortcut which has been added on Steam!!

I have ever used a RenX shortcut on Steam and everything worked fine, yet. IMO the v0.55 Launcher will work too so, just without launching RenX via an added shortcut for Steam.

The fix is now up to you guys... Do you need any more informations I could deliver?

If this hadn't helped in a way, my next step would be to rename the "SteamApi.dll" into "steam_api.dll".

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...