Jump to content

Mammoth tank not firing bug


sterps
 Share

Recommended Posts

Pls someone try to reproduce it.

It also happens with Orpaches!! It is right that this issue happens a lot more than in previous Beta releases. Well, it could be an issue like:

As before, PIC and Rave sometimes ALWAYS don't shoot with their primary weapon after switching weapons between primary and secondary, using the Carbine Rifle as an example and switching back!! It even sometimes happens after a reload. I still cannot take it when my PIC gets killed when I own a full magazine or 3/4 and am not being able to shoot ...

PIC and Rave are actually unplayable for me!! This has been a serious problem, in v4.x it is worse than before. I always switch weapons with em and their primary weapon will always be bugged so.

This has also happened with Orcas/Apaches.

My opinion about this issue is:

After a shoot, before a next round has been loaded up and you switch weapons in meantime, this weapon which was kinda reloading a next round (not a complete magazine) has been "bugged" and so cannot shoot anymore before you "globally" reload your weapons again.

Source: [RenX | Beta 4.01] PIC / Rave - shooting still bugged

Link to comment
Share on other sites

  • 2 weeks later...

To be more specific this occurs after keeping the mouse1 button pressed. I would aim at a building, press and hold the fire button and suddenly it happens. It would sometimes shoot only 1 shell, other times 3 shells, and then no shells. It is very frustrating since mammoths are prime targets and 1 bullet can make a difference

Link to comment
Share on other sites

To be more specific this occurs after keeping the mouse1 button pressed. I would aim at a building, press and hold the fire button and suddenly it happens. It would sometimes shoot only 1 shell, other times 3 shells, and then no shells. It is very frustrating since mammoths are prime targets and 1 bullet can make a difference

Confirmed.

Seems like It happens when the mousebutton 1 is pressed and hold down.

Link to comment
Share on other sites

I find it happens even when i'm not holding the mouse button down. If i click for each shot just as it's reloaded this still happens.

Lol when you hold the mouse button down it just doesn't fire but keeps reloading, over and over.

Link to comment
Share on other sites

  • 1 month later...
  • Moderator
Pls someone try to reproduce it.

I record very crappy videos, and had it happen to me when I stole one from GDI on a game of walls.

Possible reasons that may cause reproduction:

-Lag, the tanks sometimes just seem not to reload on their own. Reloading via the reload button while inside the tank fixes it. The reload button fixes it in the video

-Getting out and back in after firing a shot from the mammoth tank. When you get back in, sometimes it won't automatically reload, nor will it try to reload when you are firing while out of ammo. Again, reload button. Also likely what happened in my video.

-possibly from some form of timing with the cannons and rockets. If you fire one first, or the other first, or simultaneously, or they both need reload at the exact same time or one finishes when the other needs reload... I am not sure which of those, but it may cause one of them to get stuck without ammo. Again, usually fixed by manually pressing reload.

AMMENDUM: I also believe, something with connection or framerate and the client, can cause the mammoth tank to fire 3 cannon shots instead of 2, on a fairly frequent basis, for me. Sometimes it happens, sometimes it don't, and I can't really control the fact that when it happens it's every 2 salvos that fires 3, and it appears every extra shot does actual damage. I feel incredibly like I am cheating despite nothing I can do to prevent myself besides hand-hold every button press to count my shots manually.

It says 3 missiles left, but the ammo counter upon entering a new vehicle is often wrong, as well as infantry health upon exiting a vehicle.

Link to comment
Share on other sites

It happens when you press alt fire (right click) while primary fire is reloading I believe. Maybe it's the same thing as the stealth tank firing while stealth client-side? I'll go on at some point tomorrow and try to 100% reproduce it to find out exactly what is causing it.

It's related to the same bug that screws up reload times for the apache/orca/mammy. When you manually reload, it reloads BOTH weapons, but you can only shoot EITHER weapon when BOTH weapons are fully reloaded, even though one of the weapons appears on the hud as reloaded far faster.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...