Jump to content

Failed to Create the D3D9 Device error


raazberry
 Share

Recommended Posts

Whenever I try to start the game up from the launcher or even go to the settings menu from the launcher, the intial splash banner comes up and then the screen goes black then the game closes and gives me the "failed to create the D3D9 Device. This may be because the desktop is locked." I tried running it as an administrator but to no avail. When I tried to find the proper compatibility settings, it gave me the error that the location does not exist, and this location is some file located in the temporary folder.

Does anyone know a work around or a fix to this issue? If so, please assist me out on this. Thank you guys and have a great day!

SPECS(In case anyone needs to know)

2.3 ghz intel core i7 3610

8 gigs ram at 1600 mhz

Nvidia GTX 675M - Drivers 334.49

Windows 8.1

Link to comment
Share on other sites

Hi raazberry and Pellaeon,

Can you make sure your video drivers and directX drivers are up to date?

All up to date.

I just set fullscreen to "false" in the ini files (as pointed out to me by another user) and the game started and plays fine. It just refuses to accept fullscreen on my mutli-monitor system. (Three different resolutions on all monitors, and no way (or desire) to cut them off when playing a game.)

@razberry:

Here's what TomatoSlayer told me:

"Ren-X install folder > UDKGame > Config > UDKSystemSettings.ini > [systemSettings] section

Set Fullscreen = False"

Try this and see if RenX starts on your system.

Link to comment
Share on other sites

  • 3 years later...
  • Developer
Just now, lupotre said:

I have the same problem from nearly 2 months on a new PC, and every tip used to fix it hasn't worked: reinstalling direct X, reinstalling nvidia graphic drivers, reinstalling game, modifying game files, none of these seem to work....what should I do? Reinstall Windows?

 

On 2/27/2014 at 6:37 AM, Pellaeon said:

Ren-X install folder > UDKGame > Config > UDKSystemSettings.ini > [systemSettings] section

Set Fullscreen = False"

Did you try that?

Link to comment
Share on other sites

  • Developer
Just now, lupotre said:

Yes, but this means I can't play in fullscreen?

The error usually occurs when something else is in fullscreen, if I remember correctly. F11 while you're ingame will swap you between fullscreen and windowed mode.

 

Does if you change that setting?

Edited by Sarah!
Link to comment
Share on other sites

Hi @lupotre

This problem is a old UDK problem. Your Game is trying to start the Game with a resolution  that your system can't show. You need to change the resolution. Can you check your Desktop resolution? I think it is not FullHD.

I am not sure which file you need to change. Can you search in the file from @Sarah! and change ResX and ResY to a resolution your System can show and try again?

Or you can start the Game with start parameters. Do you know how?

https://docs.unrealengine.com/udk/Three/CommandLineArguments.html#Rendering

I think the Command is "?ResX=1600?ResX=900"

Can you send me you DXDiag Infos? Maybe something with your DX is wrong but I think not...

https://help.ea.com/en-au/help/pc/how-to-gather-dxdiag-information/

 

 

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...